Increased traffic caused intermittent disruptions to some services.
Resolved
Jul 9, 2026 at 10:20pm UTC
Our team identified the source of the traffic and deployed additional filtering and protection measures to mitigate the impact. All affected services have since returned to normal operation, and we've put additional safeguards in place to help prevent similar issues going forward.
We apologize for any inconvenience this may have caused.
Affected services
Created
Jul 9, 2026 at 7:30pm UTC
We detected an unusually high volume of traffic hitting our infrastructure, which impacted shared server resources and caused intermittent disruptions. Affected users may have experienced slow response times or timeouts during this period.
Affected services